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The Secret Keeper Login Window 
 

 
 

The Secret Keeper Main Window 
 
There are three parts to the Secret Keeper’s main window that are referenced in this 
manual: 

• The Menu Bar 
• The Link Panel 
• The Site Grid 
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Creating a New Password Database 
 
The first time you run Secret Keeper you will see the following window… 
 

 
 
Enter the password you want to use to unlock your password database.  This will 
probably be your favorite password, one that you can easily remember.  This will be your 
master password.  As the instruction on the window says: “Don’t forget it” 
 
Once you’ve entered your master password click on the “Create Database” button... 
 

 
 
…and launch Secret Keeper’s main window… 
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…which does not yet contain any entries in the Site Grid.  Only the “Add a new site” link 
is available on the Link Panel. 
 

Logging into an Existing Password Database 
 
Once you’ve created a password database and you start Secret Keeper again, you will be 
asked to login to your password database.  
 

 
 
Enter the master password you chose when you created your database and click on the 
“Log In” button. 
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Adding a New Site 
 
To add a new site, click on the “Add a new site” link on the Link Panel (or hold down the 
ctrl key and press the A key). 
 

 
 
A “New Item” dialog box will appear. 
 

 
 
Enter a short description of the site, your user name at that site and your password for the 
site.  These three pieces of information are required.  The “Note” field can be used to 
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information that will help you to gain access or use the site.  The “URL” field should be a 
link that will allow you to navigate to the site with your browser. 
 

 
 
Notice that in the above screenshot the password is masked.  When you click and hold 
down the “Reveal” button, however, the actual password will appear. 
 

 
 
After you click the “OK” button the “New Item” dialog box will disappear and the new 
site will appear on Secret Keeper’s Site Grid. 
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Modifying a Site 
 
To modify the information you’ve entered for a site, click on the site in Secret Keeper’s 
Site Grid and then click on the “Edit the site” link on the Link Panel (or hold down the 
ctrl key and press the M key). 
 

 
 
A dialog box like the one below will appear.   
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Change the items of information that need changing and click on the “OK” button to save 
your changes.  Click the “Cancel” button to close the dialog box without making any 
changes. 
 

 
 

Deleting a Site from your Password Database 
 
To delete a site from your password database click on the site in Secret Keeper’s Site 
Grid and click the “Delete the site” link on the Link Panel (or hold down the ctrl key and 
press the D key). 
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A dialog box will appear asking you to confirm the deletion.  
 

 
 
Click the “Yes” to delete the site or the “No” button to leave it in your database. 
 

Navigating to a Site in Your Password Database 
 
To navigate to a site in your password database select a site in Secret Keeper’s Site Grid 
and click on the “Go to the site” link on the Link Panel (or hold down the ctrl key and 
press the G key).   
 
Note that the “Go to the site” link will only be active if you have entered a URL for the 
site.  Otherwise, it will be grayed out. 
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When you click an active “Go to the site” link (or press ctrl+G), your default browser 
will attempt to go the URL entered for the site and open that site for you. 
 

Advanced Tip: Normally, when you enter information for a site, you will enter 
information for a website and your URL will look something like:  

“http://www.mysite.com”.   
It is, however, possible to enter information for an application on your computer that 
requires a password.  In this case your “URL” would be a file path to that application 
and look something like:  

“C:\Program Files\MyApplication\MyApplication.exe” 
 

What Happens When You Navigate to a Site or Minimize Secret 
Keeper? 
 
After Secret Keeper has started navigating to a site, its main window disappears and 
Secret Keeper is represented by an icon in your computer’s system tray. 
 

 
 
The same thing happens when you minimize Secret Keeper by clicking its minimize 
button. 
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The Menu on the Tray Icon 
 
When you right-click the Secret Keeper icon in the system tray a menu appears. 
 

 
 
This menu is designed to help you use Secret Keeper when you have your browser 
opened to a website that you need a user name and password for.   

Tray Menu – Copy Username 
 
To copy your username for a site to the clipboard: 

• Right-click on the Secret Keeper tray icon to bring up the menu.   
• The text enclosed in square brackets should be the name of the site you need the 

username for. 
• Click the “Copy Username” item on the menu. 

 

  
 
In your browser: 

• Click on the username field on your site’s login. 
• Paste the username from the clipboard into the username field (hold down the ctrl 

key and press the V key). 
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Tray Menu – Copy Password 
 
To copy your password for a site to the clipboard: 

• Right-click on the Secret Keeper tray icon to bring up the menu.   
• The text enclosed in square brackets should be the name of the site you need the 

password for. 
• Click the “Copy Password” item on the menu. 

 

 
 
In your browser: 

• Click on the password field on your site’s login. 
• Paste the password from the clipboard into the password field (hold down the ctrl 

key and press the V key). 
 

Tray Menu – Copy URL 
 
To copy a URL for a site to the clipboard: 

• Right-click on the Secret Keeper tray icon to bring up the menu.   
• The text enclosed in square brackets should be the name of the site you need the 

password for. 
• Click the “Copy URL” item on the menu. 

 

 
 
In your browser: 

• Select the browser’s web address area. 
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• Paste the URL from the clipboard into the address area (hold down the ctrl key 
and press the V key). 

• Navigate to the URL. 
 

Tray Menu – Go To Site 
 
To navigate to a site from the tray menu: 

• Right-click on the Secret Keeper tray icon to bring up the menu.   
• The text enclosed in square brackets should be the name of the site you need the 

password for. 
• Click the “Go To Site” item on the menu. 

 

 
 
When you click an active “Go To Site” menu item, your default browser will attempt to 
navigate to that site for you. 
 

Tray Menu – Navigate 
 
To activate a navigation control that you can use while your browser is open: 

• Right-click on the Secret Keeper tray icon to bring up the menu.   
• Click the “Navigate” item on the menu. 
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The Navigation Control 
 
The following popup window will appear somewhere on your computer’s screen after 
you have clicked the “Navigate” item on the Tray Menu. 
 

 
 
The Navigation Control can be set to “Stay on Top”.  When this is set, the Navigation 
Control will always be on top of other windows that you may have open; but you can 
move it around so it is not in your way.   
 
When “Stay on Top” is not set, the following rules apply:  

• Whenever you click on the Secret Keeper Tray Icon the Navigation Control will 
appear and you can move it around so it is not in your way.   

• Whenever you select another application (like your browser) the Navigation 
Control will move behind the selected application; but you can bring it forward 
again by clicking on the Secret Keeper Tray Icon. 

 
The Menu is used to initiate action on the selected site in Secret Keeper.  The currently 
selected site is shown in the middle of the control’s window.  The Navigation buttons are 
used to select different sites. 
 

Navigation Control – Select First 
 
To select the first site in your Secret Keeper database from the Navigation Control, click 
on the far left button. 
 

     

Navigation Control – Select Previous 
 
To select the site that is just previous to the one currently selected, click the button just to 
the left of the middle. 
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Navigation Control – Select Next 
 
To select the site that follows the one currently selected, click on the button just to the 
right of the middle. 
 

 
 

Navigation Control – Select Last 
 
To select the site that is the last one in your Secret Keeper database, click on the far right 
button. 
 

   
 

Navigation Control – Menu 
 
Click on the “Menu” in the Navigation Control to bring up its menu. 
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Navigation Control – Menu – Copy User Name 
 
To copy your username for a site to the clipboard: 

• Click on the Navigation Control Menu to bring up the menu.  Click the “Copy 
Username” item on the menu. 

• Or when the Navigation Control is selected hold down the ctrl key and press the 
N key. 

 

 
 
 

Navigation Control – Menu – Copy Password 
 
To copy your username for a site to the clipboard: 

• Click on the Navigation Control Menu to bring up the menu.  Click the “Copy 
Password” item on the menu. 

• Or when the Navigation Control is selected hold down the ctrl key and press the 
P key. 

 

 
 

Navigation Control – Menu – Copy URL 
 
To copy your username for a site to the clipboard: 

• Click on the Navigation Control Menu to bring up the menu.  Click the “Copy 
URL” item on the menu. 

• Or when the Navigation Control is selected hold down the ctrl key and press the 
U key. 
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Navigation Control – Menu – Go To URL 
 
To navigate to a site: 

• Click on the Navigation Control Menu to bring up the menu.  Click the “Go To 
URL” item on the menu. 

• Or when the Navigation Control is selected hold down the ctrl key and press the 
G key. 

 

 
 

Navigation Control – Menu – Close Navigator 
 
To close the Navigation Control: 

• Click on the Navigation Control Menu to bring up the menu.  Click the “Close 
Navigator” item on the menu. 

• Or when the Navigation Control is selected hold down the ctrl key and press the 
X key. 

 

 
 

Navigation Control – Menu – Stay On Top 
 
When the Navigator Control is set to “Stay On Top”, you can unset it in the following 
way: 

• Click on the Navigation Control Menu to bring up the menu. 
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• Click on the “Stay On Top” item to uncheck it and unset the “Stay On Top” 
mode. 

 
When the Navigation Control is not set to “Stay On Top”, you can set it in the following 
way:  

• Click on the Secret Keeper Tray Icon to bring the Navigation Control forward. 
• Click on Navigation Control Menu to bring up the menu. 
• Click on the “Stay On Top” item to check it and set the “Stay On Top” mode. 

 

 
 

Tray Menu – Show 
 
To show the Secret Keeper’s main window, when it hidden (either because you have 
minimized Secret Keeper or you have selected to go to a URL from Secret Keeper): 

• Right-click on the Secret Keeper tray icon to bring up the menu.   
• Click the “Show” item on the menu. 

 

 
 

Tray Menu – Hide 
 
To use the Tray Menu to hide the Secret Keeper’s main window, when it not hidden: 

• Right-click on the Secret Keeper tray icon to bring up the menu.   
• Click the “Hide” item on the menu. 
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Tray Menu – Exit 
 
To exit from Secret Keeper with the Tray Menu: 

• Right-click on the Secret Keeper tray icon to bring up the menu.   
• Click the “Exit” item on the menu. 

 

 
 

Main Window – Link Panel – Additional Commands 
 
The three copy commands available on the Tray Menu are also available on Secret 
Keeper’s Link Panel: 

• Copy Username 
• Copy Password 
• Copy URL 

 
To copy the user name for a site to the clipboard: 

• Select the site in the Site Grid. 
• Click on the “Copy the user name” link on the Link Panel (or hold down the ctrl 

key and press the N key). 
 
To copy the user password for a site to the clipboard: 

• Select the site in the Site Grid. 
• Click on the “Copy the password” link on the Link Panel (or hold down the ctrl 

key and press the P key). 
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To copy the URL for a site to the clipboard: 
• Select the site in the Site Grid. 
• Click on the “Copy the URL” link on the Link Panel (or hold down the ctrl key 

and press the U key). 
 

 
 

Menu Bar – Logout 
 
To logout from your Secret Keeper database without exiting the application: 

• Click on the “File” menu item on the menu bar to bring up the File menu. 
• Click on the “Logout” item. 

 

 
 

Menu Bar – Exit 
 
To exit from the Secret Keeper application: 
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• Click on the “File” menu item on the menu bar to bring up the File menu. 
• Click on the “Exit” item. 

 

 
 

Menu Bar – Password Change 
 
To change your Secret Keeper master password: 

• Click on the “Password” item on the Menu Bar to bring up the Password menu. 
• Click on the “Change” item. 

 

 
 
 
A dialog box will appear on your screen.   

• Enter a new password in the “New Master Password” field and the same 
password in the “Confirm Password” field. 

• Click the “Change” button to change your master password. 
• Click the “Cancel” button to keep your old password. 
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Menu Bar – Tools – Backup 
 
To backup your Secret Keeper password database: 

• Click on the “Tools” item on the Menu Bar to bring up the Tools menu. 
• Click on the “Backup” item on the Tools menu. 

 

 
 
A file save dialog box will appear.  In the folders pane of the dialog box navigate to a 
folder that you want to use for your backup (you may want to use a flash drive or a 
network drive for your backup just in case something happens to the files on your 
computer’s hard drive).  Click the “Save” button to make the backup 
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Menu Bar – Tools – Restore 
 
To restore your Secret Keeper database from a backup: 

• Click on the “Tools” item on the Menu Bar to bring up the Tools menu. 
• Click on the “Restore” item on the Tools menu. 
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A dialog box will appear that asks to confirm that you want to replace your Secret Keeper 
database with a backup version.  Click the “Yes” button to proceed.  Click the “No” 
button to leave your database as it is. 
 

 
 
After you click “Yes” an open file dialog box will appear.  In this dialog box navigate to 
the drive and folder where you made your backup, select the “Data.edb” file and click the 
“Open” button to restore the database file or “Cancel” to leave your database as it is. 
 

 
 

Menu Bar – About 
 
To see the version of Secret Keeper that you are using, click on the “About” item on the 
Menu Bar. 
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Menu Bar – Exit 
 
As an alternative to the File | Exit menu selection, you can click on the “Exit” item on the 
Menu Bar. 
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